[Logo] Mentawai Forum - Mentawai Web Framework
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 

Forum Read-Only! Check the new site and forum here!

EL linguagem de expressão  XML
Forum Index -> Comentários Gerais
Author Message
jhonrico



Joined: 29/08/2005 11:42:33
Messages: 3
Offline

Como que funciona a EL no mentawai:
porque eu fiz um:

output.setValues("user",user);

e na pagina jsp fiz:
${user}

não funcionou..

saoj



Joined: 01/07/2005 09:59:17
Messages: 2846
Location: Rio de Janeiro, RJ
Offline

Vc deu forward ???

Vc configurou EL direito ???

Faça isso para testar:

Code:
 <%
 String user = "aaaa";
 request.setAttribute("user", user);
 %>
 <h1>${user}</h1>
 


Sergio Oliveira

jhonrico



Joined: 29/08/2005 11:42:33
Messages: 3
Offline

não funcionou EL
<br>
<%
String user="aa";
request.setAttribute("user",user);
%>
usuario:${user}
</body>
saoj



Joined: 01/07/2005 09:59:17
Messages: 2846
Location: Rio de Janeiro, RJ
Offline

Vc não está configurando o EL direito na sua página.

Isso aqui pode ajudar:

http://www.guj.com.br/posts/list/27092.java

Sergio Oliveira

jhonrico



Joined: 29/08/2005 11:42:33
Messages: 3
Offline

foi so eu colocar o web.xml para 2.4 que funcionou..

mas quando eu faço um

output.seValues("user",user);

e depois no applicationmanager
ac.addConsequence(LoginAction.SUCCESS, new Redirect "/welcome.jsp"));
ac.addConsequence(LoginAction.ERROR, new Forward("/login.jsp"));
addActionConfig(ac);

quando eu colocar na paina welcome.jsp ${user} não funciona
saoj



Joined: 01/07/2005 09:59:17
Messages: 2846
Location: Rio de Janeiro, RJ
Offline

Redirect perde tudo !!!!!!!!!!!

Tem que ser forward...


Sergio Oliveira

 
Forum Index -> Comentários Gerais
Go to:   
Powered by JForum 2.1.6 © JForum Team