[Logo] Mentawai Forum - Mentawai Web Framework
  [Search] Search   [Recent Topics] Recent Topics   [Members]  Member Listing   [Groups] Back to home page 
[Register] Register / 
[Login] Login 

Forum Read-Only! Check the new site and forum here!

Erro no JSON  XML
Forum Index -> Comentários Gerais
Author Message
mamangava


[Avatar]

Joined: 05/10/2009 14:11:11
Messages: 7
Location: Pouso Alegre, Minas Gerais
Offline

Galera segue abaixo o log do tomcat com o erro ques está ocorrendo.

Code:
 14/07/2011 16:54:08 org.apache.catalina.core.StandardWrapperValve invoke
 GRAVE: Servlet.service() for servlet Controller threw exception
 java.lang.NoSuchMethodError: net.sf.json.JSONObject.put(Ljava/lang/String;Ljava/lang/Object;)Lnet/sf/json/JSONObject;
 	at org.mentawai.ajax.renderer.JSONGenericRenderer.convertMap(JSONGenericRenderer.java:268)
 	at org.mentawai.ajax.renderer.JSONGenericRenderer.buildJSON(JSONGenericRenderer.java:99)
 	at org.mentawai.ajax.renderer.JSONGenericRenderer.encode(JSONGenericRenderer.java:77)
 	at org.mentawai.ajax.AjaxConsequence.execute(AjaxConsequence.java:106)
 	at org.mentawai.core.Controller.service(Controller.java:655)
 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
 	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
 	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
 	at org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:864)
 	at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:579)
 	at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1665)
 	at java.lang.Thread.run(Thread.java:662)
 


O que será que pode ser isso?!

Já tentei bastante coisa, troquei a lib da json por uma mais nova, por uma mais antiga e nada adiantou, continua com esse mesmo erro.

Atenciosamente,

Rafael.
[WWW] [MSN]
 
Forum Index -> Comentários Gerais
Go to:   
Powered by JForum 2.1.6 © JForum Team